Table of contents
Why This Lab Matters (And Why You Should Care)
If you’re serious about passing your CCNA (or just want to actually understand how routers make decisions), this is the lab for you.
This is where the magic happens — where packets leave your computer, travel across multiple routers, and finally land at their destination.
It’s not enough to memorize static route commands. You need to see them in action. You need to know exactly how a router reads the routing table, picks the next hop, and forwards packets to the right destination.
That’s exactly what this lab delivers. You’ll build a multi-router network, configure static routes, trace packets hop-by-hop, and uncover exactly how the logical IP routing process works from start to finish.
By the end, you’ll have a rock-solid understanding of how logical IP routing decisions work — the foundation for every advanced networking skill you’ll ever learn.
Watching the video is a great start, but don’t stop there! Use the workbook to recreate this setup step by step and practice until you’re comfortable with every configuration. Each time you build the lab, you’ll learn something new. Remember, practice is the key to mastering networking concepts.
Lab Summary
- Lab Name: Logical Routing and Path Selection
- Lab Difficulty: Intermediate
- Approximate Time: 45-60 minutes
- Preferred Image: iol-l3
- Book Reference: CCNA 200-301 Official Cert Guide, Volume 1 (2nd Edition) – Cisco Press
- Lab on: Chapter 3: Fundamentals of WANs and IP Routing
- Figure: 3-10 (Routing Logic: PC1 Sending an IP Packet to PC2)
What You’ll Set Up
- 3 routers creating a simple multi-hop network.
- 2 PCs in different subnets, each connected to separate routers.
- Static routes ensuring proper path selection between devices.
This lab brings logical IP routing and static route configuration to life.
Network Structure
- PC1 (Source): 150.150.1.10/24 (Connected to R1)
- PC2 (Destination): 150.150.4.10/24 (Connected to R3)
- Router Connections:
- R1 to R2: Serial Link (150.150.2.0/30)
- R2 to R3: Ethernet Link (150.150.3.0/30)
Sample Routing Table Details:
Router | Subnet | Outgoing Interface | Next Hop |
---|---|---|---|
R1 | 150.150.4.0/24 | Serial1/0 | 150.150.2.7 |
R2 | 150.150.4.0/24 | Ethernet0/0 | 150.150.3.1 |
R3 | 150.150.4.0/24 | Ethernet0/1 | Directly Connected |
Topology Diagram
Below is the topology diagram for this lab setup:

(Refer to Figure 3-10: Routing Logic: PC1 Sending an IP Packet to PC2)
Prerequisites
You’ll need:
- EVE-NG up and running.
- 3 working iol-l3 router images.
- 2 vPCS devices for PC1 and PC2.
- Basic knowledge of static routing, IP addressing, and subnetting.
Implementation Steps:
Step 1: Build the Topology
- Add these devices in EVE-NG:
- Connect the devices:
- PC1 to Router1’s Ethernet interface (Ethernet0/1).
- PC2 to Router3’s Ethernet interface (Ethernet0/1).
- Router1 to Router2 via a serial link (Serial1/0).
- Router2 to Router3 via an Ethernet link (Ethernet0/0).
Why This Step? Without a clear and correct physical topology, your routing logic won’t make sense. Think of this like building the roads before installing traffic signs — no network, no routing.
Step 2: Configure Router1 (R1)
1. Configure the LAN interface:
Router#configure terminal
Router(config)hostname R1
R1(config)#interface ethernet0/1
R1(config-if)#ip address 150.150.1.4 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
2. Configure the WAN interface:
R1(config)#interface serial1/0
R1(config-if)#ip address 150.150.2.6 255.255.255.0
R1(config-if)#encapsulation hdlc
R1(config-if)#no shutdown
R1(config-if)#exit
3. Add a static route:
R1(config)#ip route 150.150.4.0 255.255.255.0 150.150.2.7
R1(config)#ip route 150.150.3.0 255.255.255.0 150.150.2.7
Why This Step? These static routes give Router1 (R1) the instructions it needs to forward packets to the right router. Without these manual path selections, R1 would have no clue where to send traffic for PC2.
Step 3: Configure Router2 (R2)
1. Configure the WAN interface to Router2:
Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface serial1/0
R2(config-if)#ip address 150.150.2.7 255.255.255.0
R2(config-if)#encapsulation hdlc
R2(config-if)#no shutdown
R2(config-if)#
*Feb 25 12:44:34.413: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
*Feb 25 12:44:35.414: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R2(config-if)#exit
2. Configure the LAN interface to Router2:
R2(config)#interface ethernet0/0
R2(config-if)#ip address 150.150.3.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
*Feb 25 12:45:05.438: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
R2(config)#
*Feb 25 12:45:06.439: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
3. Add static routes:
R2(config)#ip route 150.150.4.0 255.255.255.0 150.150.3.1
R2(config)#ip route 150.150.1.0 255.255.255.0 150.150.2.6
Why This Step? R2 acts as the middle router in your multi-router network. It needs clear next-hop instructions to make the right routing decisions for traffic heading to both PC1 and PC2.
Step 4: Configure Router3 (R3)
1. Configure the LAN interface:
Router>enable
Router#conf t
Router(config)#hostname R3
R3(config)#interface ethernet0/1
R3(config-if)#ip address 150.150.4.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
2. Configure the WAN interface to Router3:
R3(config)#interface e0/0
R3(config-if)#ip address 150.150.3.1 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
3. Add a static route:
R3(config)#ip route 150.150.2.0 255.255.255.0 150.150.3.2
R3(config)#ip route 150.150.1.0 255.255.255.0 150.150.3.2
Why This Step? Without these static routes, R3 wouldn’t know how to send replies back to PC1. Static routes make logical path selection predictable and testable.R2.
Step 5: Configure LAN Hosts (PC1 & PC2)
1. Configure PC1:
ip 150.150.1.10 255.255.255.0 150.150.1.4
2. Configure PC2:
ip 150.150.4.10 255.255.255.0 150.150.4.1
Why This Step? Correct IP and default gateway configuration ensures PC1 and PC2 know where to send traffic — without it, packets would never leave the devices.
Verification & Testing
1. Ping Tests:
- From PC1 to PC2:
ping 150.150.4.10
- From PC2 to PC1:
ping 150.150.1.10
2. Routing Table Validation:
- Verify that each router has routes to all subnets using:
R2#show ip route
150.150.0.0/16 is variably subnetted, 6 subnets, 3 masks
S 150.150.1.0/24 [1/0] via 150.150.2.6
C 150.150.2.0/24 is directly connected, Serial1/0
L 150.150.2.7/32 is directly connected, Serial1/0
C 150.150.3.0/30 is directly connected, Ethernet0/0
L 150.150.3.2/32 is directly connected, Ethernet0/0
S 150.150.4.0/24 [1/0] via 150.150.3.1
3. Traceroute Analysis:
- Trace the path of packets from PC1 to PC2:
PC1> trace 150.150.4.10
trace to 150.150.4.10, 8 hops max, press Ctrl+C to stop
1 150.150.1.4 0.692 ms 0.416 ms 0.684 ms
2 150.150.2.7 21.622 ms 21.210 ms 22.183 ms
3 150.150.3.1 23.265 ms 22.814 ms 21.963 ms
4 *150.150.4.10 23.626 ms
- Trace the path of packets from R1 to R3:
R1#traceroute 150.150.4.10
Type escape sequence to abort.
Tracing the route to 150.150.4.10
VRF info: (vrf in name/id, vrf out name/id)
1 150.150.2.7 12 msec 23 msec 23 msec
2 150.150.3.1 23 msec 23 msec 22 msec
3 150.150.4.10 26 msec 12 msec 23 msec
- Verify the intermediate hops (R1 → R2 → R3).
Why This Step? If any test fails, it points you directly to where your static route configuration is broken.
Troubleshooting Tips
- Common Issues:
- Incorrect IP addresses or subnet masks on interfaces.
- Missing or misconfigured static routes.
- Interfaces not enabled with no shutdown.
- Debugging Commands:
- To debug packet flow:
R3#debug ip packet
IP packet debugging is on
*Nov 28 14:59:46.740: IP: s=150.150.4.10 (Ethernet0/1), d=150.150.2.6 (nil), len 28, input feature, MCI Check(110), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Nov 28 14:59:46.740: IP: s=150.150.4.10 (Ethernet0/1), d=150.150.2.6 (nil), len 28, unroutable
*Nov 28 14:59:46.740: IP: tableid=0, s=150.150.4.1 (local), d=150.150.4.10 (Ethernet0/1) nexthop=150.150.4.10, routed via FIB
*Nov 28 14:59:46.740: IP: s=150.150.4.1 (local), d=150.150.4.10 (Ethernet0/1), len 56, sending
*Nov 28 14:59:46.740: IP: s=150.150.4.1 (local), d=150.150.4.10 (Ethernet0/1), len 56, sending full packet
R3#
*Nov 28 14:59:49.754: IP: s=150.150.4.10 (Ethernet0/1), d=150.150.2.6 (nil), len 28, input feature, MCI Check(110), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Nov 28 14:59:49.755: IP: s=150.150.4.10 (Ethernet0/1), d=150.150.2.6 (nil), len 28, unroutable
*Nov 28 14:59:49.755: IP: tableid=0, s=150.150.4.1 (local), d=150.150.4.10 (Ethernet0/1) nexthop=150.150.4.10, routed via FIB
*Nov 28 14:59:49.755: IP: s=150.150.4.1 (local), d=150.150.4.10 (Ethernet0/1), len 56, sending
*Nov 28 14:59:49.755: IP: s=150.150.4.1 (local), d=150.150.4.10 (Ethernet0/1), len 56, sending full packet
R3#
- To resolve ARP-related issues:
R2#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 150.150.3.1 13 aabb.cc00.3000 ARPA Ethernet0/0
Internet 150.150.3.2 - aabb.cc00.2000 ARPA Ethernet0/0
Verification Commands
1. Check Interface Status:
show ip interface brief
2. Verify Routing Table:
show ip route
3. Ping to Test Connectivity:
ping <Destination IP>
4. Trace Route to Follow Packet Path:
traceroute <Destination IP>
Key Commands
Router Configuration:
1. Interface IP Configuration:
interface <interface>
ip address <IP Address> <Subnet Mask>
no shutdown
2. Static Routing Configuration:
ip route <Destination Network> <Subnet Mask> <Next Hop>
Key Takeaways
- Understand exactly how routers read routing tables.
- Learn how to manually control packet forwarding with static routes.
- Use traceroute to track logical packet paths across multi-router networks.
Real-World Application
This is real networking 101 — from branch office setups to ISP routing, logical path selection is at the heart of every IP network.
Common Pitfalls
- Forgetting no shutdown on interfaces.
- Missing static routes (especially return routes).
- Mixing up next-hop IP addresses.
Validation Checklist
- Device Status: All interfaces are up/up (use show ip interface brief).
- Routing Table: Each router has valid static routes for all subnets (show ip route).
- Connectivity: Successful pings between PC1 and PC2.
- Path Validation: traceroute confirms the path through R1 → R2 → R3.